Úvod
 Top Next
Program Nset

jednoduchý program pro nastavení parametrů vrátného NUDV.
Program se skládá z několika funkčních celků :
  • Formuláře s parametry
  • Práce se soubory
  • Komunikace s vrátným
  • Tisk nastavení
  • Vyplnění a tisk vizitek
  • Doplňkové funkce
  • Jak lze dálkově programovat
  • Návod k použití NUDV

Před úpravami a zápisem parametrů do vrátného nezapomeňte nejprve načíst z vrátného jeho současné nastavení.


Formuláre s parametry

Formuláře s parametry
 Previous Top Next
Jsou dvě možnosti provedení změny parametru
  • výběr předdefinované hodnoty (kliknutím myši)
  • vyplnění okénka (lze zadat pouze povolené znaky, rozsah se automaticky opraví po opuštění okénka)

Pro snadnější obsluhu např. z klávesnice Notebooku je provedena možnost zadávat znak:
* - klávesa "h" nebo "H"
# - klávesa "k" nebo "K"

Pro zadání "Flash" se používá klávesa "f" nebo "F"
Pro zadání "Pauza" se používá klávesa "p" nebo "P"

Parametry vrátného

Úvod


Parametry vrátného
Základní parametry
Zde se nastavují základní funkce jako je druh volby znak pro prodloužení hovoru * nebo #, povel pro zavěšení vrátného z telefonu, servisní heslo pro vstup do programování, povel pro přepnutí do režimu DEN a NOC z telefonu (při hovoru s vrátným), režim volby čísel (1. nebo 2. skupina nebo volba podle nastavení DEN / NOC), připojení NC-mod nebo klávesnice, a dále na klávesnici volba čísla jako na normálním telefonu nebo volba z čísla paměti - na klávesnici se zadává pouze 2-místné číslo paměti, pod kterou je číslo volaného uloženo.
Spínače
Pro každý spínač se vybírá mód spínání, hesla z tlačítek nebo klávesnice pro různé režimy, kód pro sepnutí spínače z telefonu (při hovoru), čas sepnutí spínače a nakonec parametr zda je možno ovládat spínač při příchozím hovoru.
Poslední společný parametr je čas mezi sepnutím spínače 1 a 2, pokud je nastaven mód druhého spínače m = 5.

Časové parametry
zde se nastavují časové parametry pouze v případě, že nevyhovují přednastavení z firemního nastavení nebo je třeba přizpůsobit tyto parametry použité telefonní lince.
  • počet vyzvánění příchozího hovoru, vrátný zvedá vždy mezi zvoněními a to 2 sec po detekci n – tého zvonění
  • maximální doba po kterou je vrátný vyvěšen, tuto dobu lze během hovoru prodlužovat volbou znaku z telefonu (* nebo #)
  • maximální doba [sec] mezi stisky tlačítek
  • normální tlačítka
    • sepnutí spínače – pokud je doba mezi zmáčknutím dvou po sobě následujících tlačítek větší než zadaná doba, tak se kód nevyhodnotí správně
    • volba čísla – pokud je tlačítko, které zmačkneme prvním číslem hesla pro sepnutí spínače, tak je volba zpožděna o tuto dobu
  • klávesnice
    • sepnutí spínače – pokud je doba mezi zmáčknutím dvou po sobě následujících tlačítek větší než zadaná doba, tak se kód nevyhodnotí správně
    • volba čísla
    • volba jako z telefonu, pokud je doba po naposledy zmáčknutém tlačítku větší než zadaná doba , pak je zahájena volba, pokud je číslo neúplné, pak je nutno zavěsit (klávesa X) a volbu opakovat.
    • volba z paměti, pokud je doba po prvním zmáčknutém tlačítku delší než zadaná doba, pak se musí zadání čísla paměti opakovat
    • doba [sec] na kterou vrátný zavěsí, než opět vyzvedne pro opakování volby (zmáčknutí tlačítka během hovoru nebo volby, detekce obsazovacího tónu)
    • doba [sec] po vyzvednutí vrátného, než začne volit. Tato doba je pro každou ústřednu jiná, ale zpravidla většina ústředen dokáže zpracovat volbu do 2 sec po vyzvednutí linky.
    • po skončení volby počítá počet KVT (kontrolních vyzváněcích tónů), pokud je číslo větší než h, tak zavěsí [rozsah 04-99]. Volbu opakuje v případě, že je nastaven režim vytáčení 2 skupin.
    • doba trvání tónu DTMF volby
    • doba trvání mezery mezi tóny DTMF volby
    • doba trvání Flash
    • doba trvání pauzy je dobou trvání mezičíslicové mezery u impulsní volby

    Přímá volba čísel
    tlačítka nebo paměti, vyplňte u příslušného tlačítka číslo, které má vrátný vytočit a to buď 1.  2. skupina nebo režim Den / Noc. Pro snadnější zadávání lze využít kláves:
    * - klávesa "h" nebo "H"
    # - klávesa "k" nebo "K"
    Pro zadání "Flash" se používá klávesa "f" nebo "F"
    Pro zadání "Pauza" se používá klávesa "p" nebo "P"


Doplòkové funkce

Doplňkové funkce
Program Nset je vybaven doplňky:
  • ukázky tónů vrátného (tato služba je přístupná pouze pro počítače se zvukovou kartou). Najdete v Nástroje - Ukázky tónů , po zmáčknutí příslušného tlačítka se se přehraje odpovídající tón vrátného
  • v nabídce Pomoc - O programu je možno kliknutím na odkaz nebo logo se připojit na stránky výrobce, při kliknutí na odkaz na Emailu lze napsat zprávu (např. objednávku) přímo výrobci


Práce se soubory
Nabídka Soubory obsahuje volby:
Otevřít – otevře soubor s nastavením pro NUDV, soubory mají masku *.UDV, pokud soubor nebude souborem pro nastavení tak to program oznámí a nastavení se nezmění.
Uložit – uloží nastavení do aktuálně otevřeného souboru, pokud není, tak vyvolá nabídku Uložit jako
Uložit jako – nastavení z programu uloží do souboru (*.UDV)

Soubory typu *.UDV jsou registrovány po instalaci ve Windows, po poklepání na soubor xxx.UDV se automaticky spustí program Nset a v něm se automaticky otevře soubor xxx.UDV.


Komunikace s vrátným
Komunikace se skládá ze dvou hlavních funcí Načtení a Zápis.
Obě funkce jsou rozděleny podle obsahu na :
vše – zápis/načtení všech parametrů vrátného
nastavení – zápis/načtení pouze všech parametrů nastavení (kromě čísel pod tlačítky)
paměti čísel – zápis/načtení pouze čísel pod tlačítky(paměti)

Pro správnou funkci musíte mít:
  1. nastaven sériový port (nabídka Nástroje-Nastavení portu , nabízí se pouze dostupné porty na vašem počítači)
  2. použít kabel pro nastavování vrátného (KAB)
  3. telefonní linku, nebo její simulátor
Postup:
  1. vrátného připojíme na linku
  2. zasuneme do konektoru PRG kabel KAB (vrátný vyzvedne linku, LED na předním panelu svítí) a připojíme k PC
  3. spustíme program Nset – vrátný se přihlásí do programování (LED na předním panelu bliká v sekundovém intervalu)
  4. ukončení komunikace se provede vysunutím kabelu KAB z vrátného NUDV (vrátný do 5 sec zavěsí), po dobu zasunutého kabelu je vrátný v aktivním stavu pro sériovou komunikaci.

Při tomto postupu se při spuštění programu automaticky načte verze firmware, počet neosazených tlačítek, režim (Den/Noc) a počet připnutí vrátného na linku (resetů). Kromě počátečního spuštění programu lze tyto parametry načíst kdykoli z připojeného vrátného kliknutím na zobrazení režimu, počtu zapnutí nebo na spodní lištu (zobrazení verze firmware).

Při jiném postupu se stane, že program zobrazí hlášení "Chyba komunikace", v tomto případě klikněte na OK a akci opakujte, pokud se ani po dalším pokusu nepodaří navázat komunikaci, pak ověřte číslo sériového portu, připojení kabelu a připojení vrátného na linku.

Barevné zobrazení stavu sériového přenosu


Barevné zobrazení stavu sériového pøenosu

Barevné zobrazení stavu sériového přenosu
Mezi tlačítky pro čtení a zápis se zobrazuje barevně příslušný stav komunikace s vrátným.

Červená barva znamená chybu
Žlutá dokončení zápisu/čtení čísel pamětí/tlačítek.
Modrá načtení verze, režimu, počtu neosazených tlačítek, a počtu zapnutí
Zelená načtení čísel pamětí/tlačítek
Bleděmodrá načtení parametrů
Olivová zápis parametrů
Tmavě fialová zápis čísel pamětí/tlačítek


Tisk nastavení
Nachází se v nabídce Soubory-Tisk nastavení. Po výběru se objeví standardní dialogové okno, kde si vyberete tiskárnu, případně změníte její nastavení a po stisku OK proběhne tisk jednoduchého reportu s aktuálním nastavením. Pro úsporu papíru se čísla pod tlačítky (paměti) tisknou pouze vyplněná.


Vyplnìní a tisk vizitek

Vyplnění a tisk vizitek
Program Nset je vybaven službou vyplnění jmen a názvů na vizitky a jejich tisk.
Po výběru z nabídky Nástroje-Tisk vizitek se objeví okno s prázdnými štítky (24 polí – větší sestavy jsou výjimečné a není problém je tisknout na několikrát)
Štítky vyplňte jmény, názvy max. do 20 znaků, na pořadí nezáleží. Vyplněné vizitky si můžete uložit pro pozdější opravy, již uložené vizitky je možno načíst. Tisk je optimální na A4 případně A5, tiskový formulář se přizpůsobí různým rozlišením i formátům papíru.
Vytištěné štítky už zbývá jen vystřihnout a vložit pod praporky na předním panelu – viz manuál.


Jak lze dálkovì programovat

Jak lze dálkově programovat
Dálkové programování umožňuje z PC programu Nset načítat nastavení a vyplněné parametry ukládat zpět do vzdáleného NUDV.
Pro možnost dálkového programování je potřeba:
1. na vzdáleném místě mít NUDV s novým firmware V7.6 a vyšší (distribuce od léta 2007)
2. program Nset verze 3.0 a vyšší
3. zařízení BlackBox (modem DMTF) připojené na USB port počítače s Nset
4. BlackBox připojit na analogovou státní linku a znát telefonní číslo pro přímou volbu na vzdálené NUDV

V menu programu zvolte "připojit"

Pripojení se vzdáleným NUDV


Pripojení se vzdáleným NUDV
Prvním krokem připojení ke vzdálenému NUDV je výběr BlackBoxu - podle výrobního čísla CALxxxxx (k PC je možno mít připojeno více BlackBoxů)
Pak vyplňte celé telefonní číslo (P=pauza, R=flash) pro volbu na vzdálené NUDV
Dále vyplňte přístupové heslo pro vstup do programování na vzdáleném NUDV
Nyní lze kliknutím na tlačítko "připojit" zahájit navázání spojení s NUDV.

Ctení dat
Zápis dat
Ukončení pripojení


Ctení dat

Čtení dat
Čtení parametrů z NUDV je vzhledem k době přenosu dat možno zkrátit výběrem parametrů, které chceme načíst.
- parametry nastavení
- paměti pod jednotlivými tlačítky DEN / NOC
Pro snadnou analýzu problému při načtení dat lze celý proces protokolovat do souboru (do složky s nainstalovaným programem Nset se uloží soubor "LF-R- datum a čas.TXT")
Kliknutím na tlačítko "Načti data" se provede načtení zvolených parametrů.

Ukončení pripojení


Zápis dat
Zápis parametrů do NUDV je vzhledem k době přenosu dat možno zkrátit výběrem parametrů, které chceme zapsat.
- základní parametry
- časové parametry
- spínače
- paměti tlačítek (zapisují se všechny vyplněné)
Pro snadnou analýzu problému při zápisu dat lze celý proces protokolovat do souboru (do složky s nainstalovaným programem Nset se uloží soubor "LF-W- datum a čas.TXT")
Kliknutím na tlačítko "Zápis dat" se provede zápis zvolených parametrů.

Ukončení pripojení


Ukonèení pripojení

Ukončení pripojení
Pokud je BlackBox spojen se vzdáleným NUDV, tak na liště menu se zobrazuje:
- číslo BlackBoxu přes který komunikace probíhá "CALxxxxx"
- nápis "Připojeno"

Kliknutím na číslo BlackBoxu v menu se zobrazí čas připojení

Kliknutím na "Připojení" se zobrazí počet udržovacích povelů při nečinnosti (Nset provádí kontrolu připojení ke vzdálenému NUDV každých 15sec při nečinnosti)

V menu "Vzdálené připojení" kliknutím na "Odpojit" zrušíte připojení s NUDV a zavěšení linky.

POZOR: po dobu připojení je vyzvednuta telefonní linka a tak běží telefonní účet a volání!!!!!