USER Manual

GSM Gateway


USER Manual

GSM Gateway

PRIma Gate


USER Manual

Dear customer

We congratulate you on purchase our product. Our wish is to make you satisfied with the GSM Gateway completely and for a long time.

! Important!

Before you start installing this product, check whether the delivery is complete and read this manual thoroughly. The manufacturer cannot be held responsible for any damages that occurred due to incorrect use of this product in contradiction to this manual. The guarantee terms do not cover damages of the product caused by rough handling, incorrect storage or by exceeding the quoted technical parameters.


General

GSM Gateway is a compact highly sophisticated system. It supports full remote supervision and configuration via an IP network or USB port. The system has been designed and works with a lot of highly sophisticated functions, which make it fully client-oriented and highly reliable in cooperation with both GSM networks and ISDN. Configuration alterations can be made without resetting, i.e. under full operation.

Basic general features

  • Connection to the exchange through ISDN E1 interface with DSS1 signaling or QSIG
  • Connection to DTMF extension line through direct dialing
  • Connection directly to the operator or the determined line
  • Connection to the operator after a time period elapse (adjustable) to select an extension line
  • Transfer of the number of the calling subscriber in the exchange (CLIP)
  • Limitation of outgoing calls in GSM network
  • Limitation of incoming calls from GSM network
  • Priority connection through each of GSM module (LCR)
  • Setting own time rate by 1 second or only in case of establishing connection
  • Selection of the GSM service provider separately for each GSM module
  • SIM card protection using PIN
  • Detailed gate parameters setting from PC through a program for Windows 98/2000/XP
  • Channel assotiation 1:1with GSM modules
  • Call progress tone ON/OFF
  • Echo cancelation
  • Roaming ON/OFF
  • Diagnostics of ISDN lines, GSM Modules Status andCredit
  • Status of modules with signal quality
  • Statistics
  • SMS server
  • Alarm indication
  • Power supply 8-12 V DC


USER Manual

Description

The system is integrated in a 19“ sub rack of the height of 3U and depth 360 mm. The front side is open, equipped with guides for plug-in boards with front panels.


CPU Board Description

The CPU board contains a powerful processor system controlling the whole system. The board is designed on a 4-layer PCB of the size of 280x100mm. CPU board contains also four primary rate (PRI, E1) ISDN interfaces and PCM bus switching and timing circuit. E1-A interface is designed for connection to PBX and LCR functions is activated on this port. E1-B is designed for connection to PSTN and all calls from this port will be routed to E1-A port. Ports E1-C and E1-D are in present time reserved for future applications. Each of these interfaces can be configured as TERMINAL or as NETWORK independently and each of these interfaces can be configured as an input of clock synchronization with defined priority. An USB interface, an Ethernet connector (10/100 Base-T), and four RJ45 connectors with pair of E1 line status LED indicators are located on the front panel.


USER Manual

Description of LED value
GREEN | YELLOW | Description
LIGHT | DARK | Connection is OK
FLASH | DARK | No data link connection (Layer 2)
LIGHT | sometimes flash | Connection is OK, lines is not synchronized (slip)
DARK | FLASH | Signal is present but it is not OK
DARK | LIGHT | No signal
DARK | DARK | Line is not in configuration

LED LAN indicates LAN connection (LED is green – connection is OK, yellow LED flash when LAN is under way).


RJ45

RJ45 pin setting

Swapping of the transmitting and receiving connector pair can be made either automatically according NT or TE configuration setting or manually according user setting. For this selection is not need to switch any jumpers on CPU board – all can be made using Configuration software see(Expert Settings).


GSM peripheral Board

The GSM board contains four GSM modules (Siemens TC35i), circuits for their connection to the PCM bus, and DTMF receivers. The board is designed on a 4-layer PCB of the size of 280x100mm. Four antenna connectors and 4 GSM status indicators are located on the front panel.

Possible statuses of indication LED diodes
LED Color | Description
NONE | Module is Not configured
GREEN LIGHT | Connection in process (call)
GREEN FLASH | Module logged in the network, rest conditionon Signal quality flash: 1 per 4 sec the lowest 5 per 4 sec the highest
RED LIGHT | GSM module is not presented
RED FLASH | other ERRORs see Error states
ORANGE LIGHT | SMS comunication
ORANGE FLASH | ERROR fast flash Initialization slow flash No Network


SMS server

USB connector of peripheral board can be used as the SMS server.
Only first module on optional board can be used as the SMS server. If SMS communication is working you can see status of Module Card in Diagnostics.


Configuration

GSM gateway configuration

This program allows you to configure and control your gateway. In top menu you can set all parameters through items File, View, Connection, Options and Service. First you install proper interface in menu Option Interface to configure other items. Some parameters you can set through the use of item in toolbar ( New, Open, Save, Download from Gateway and Upload to Gateway ).


File

Section File allows you to define New file of configuration and save it as a *.cfg or Open an existing configuration file. After setting configuration you can Save it or Save as. This configured file you can retain in Upload to Gateway. Setting of configuration you can read from the gateway throught item Download from Gateway. You can download call detailed records from Gateway throught item Download CDR. You can see recent saved files (max 6) in section Recent file. There is an item for program end too (section Quit).


New

In this pane you can create the new configuration and load default setting in the tree and set or change it.


New

Open

Program opens a file from a folder selected by you.


Save

Program saves a file of configuration.


Save as

Program saves the file into a folder selected by you.


Close

Terminates setting configuration.


Download

Download from Gateway

If you extract from Menu File this item you can download last-saved configuration file from gateway.


Upload

Upload to Gateway

This item allows you to save your configuration file to gateway.


Download CDR

If you extract from Menu File this item you can download call detailed records (*.csv) from gateway.Description of cdr line is in Appendix.


Recent file

There are recent saved files of configuration (last 6).


Quit

Terminates the program.


View

Section View, allows you to display or not Toolbar and Status bar.


Toolbar

Display or hide toolbar with items New, Open, Save, Download from Gateway, Upload to Gateway and information about program.


Status

Display or hide status line on the bottom of pane.


Connection

Section Connection allows you to connect or disconnect COM port.


Options

Section Options allows you to to set Interface, Language, Password and Date/Time.


Interface

Select COM port

Choose proper COM port, which makes communication gateway with your PC.


Language

English.


Password

You can set or change password for access to gateway. Password is saved in Gateway.


Date / Time

You can set or change date and time in the Gateway.


Service

Section Service displays System Information and contains commands for the gateway as General Reset, Update firmware, Module Reset and allows display System Monitor (available only if the GSM Gateway is connected).


System information

This item displays System information.


General Reset

System restarts the gateway and initializes all Gateway boards (the gateway communication is not discontinued but all current calls and SMS to be sent are terminated!).


Update firmware

System writes firmware (file *.LMF) into Gateway.
Warning! If you can write firmware from network and the connection is unstable it is possible failure of update firmware.


Module reset

You can choose the GSM module to reset it.


System Monitor

This pane is used for storing traces from ISDN layers (sending and receiving messages) for possible check in case of problems.

You can Start or Stop (and save) tracing of messages with filter at right part of this pane.


Configuration

In this pane you can set gateway's parameters as System, ISDN, GSM, LCR (Least Cost Routing) and CLIP from GSM.


System

This pane allows you to assign Name for identification of Gateway (General), to set network parameters (Network) and Alarm Indication.


General

In this section you can type name of your equipment.


Network

In this section you can set parameters as IP address, subnet mask, IP address of default gateway and number of port.


Alarm

Alarm indication

In this section you can set max 5 numbers. Gateway will send SMS message to these numbers in case of trouble with some GSM module. Description of Alarm Message is in appendix.


ISDN

This pane contains setting of ISDN line. You can set Common properties, options for each Lines and Synchronization.


Common

Dial tone

  • No dial tone
    Gateway will not send any dial tone towards PBX on empty SETUP (in case that receive SETUP message without called party number).

  • Continuous tone
    Gateway sends continuous dial tone.

  • Tone Morse A
    Selection of type of dial tone (330 ms pulse, 330 ms pause, 660 ms pulse, 660 ms pause).

Wait for next digits

Time (1-60 seconds) to wait for next digit. This timeout causes the end of dialing from PBX.

Time to save smart callback

Time (0-48 hours) for saving callback information in Gateway smart callback table.
'0' means that smart callback function is disabled.

Channel assotiation 1:1 with GSM modules

Each channel from PBX has fix channel of GSM module.
For example: 1.voice channel is connected to 1. GSM module and vice versa, GSM modules 31, 32 are unused.

Call progress tone

User of PBX will hear progress tone or will not it.

Timeout if extension does not answer

Time in seconds. Default is 30 seconds.


Lines

In this section you can set options for each line (PBXE1-A, PSTNE1-B, E1-C, E1-D).

  • Protocol

    • Signalization

      You can define type of signalization:
      • DSS1 (ITU-T Q.931)
      • Q-SIG
      • disabled.
      You can configure the line as network (NT) or terminal (TE).

  • L1 Parameters

    • CRC4
      Parameter for activating/deactivating CRC of Layer 1 on PRI ISDN interface.

  • L3 Parameters

    Defines way of occupation of B-channels on PRI interface.
    • Upwards channel selection (A side)
      Gateway will occupy channels from channel 1 to 32.

    • Downwards channel selection (B side)
      Gateway will occupy channels from channel 32 to 1.

    • Cyclic channel selection
      Gateway will occupy channels from last engaged +1/-1 channel.

  • Channel's Blocking

    This setting allows to block unused channel.

  • Expert Settings

    This pane contains other parameters of lines. This setting is not recommended to change.

    • L1 Parameters
      Parameters for L1 layer.
      Long Haul
      This setting is not recommended to change (only the Gateway is placed far away from PBX approximately 300m and PBX takes part of it).

    • RJ45 pin setting
      You can choose from 3 options of RJ45 pin setting: According to the protocol, Always TE or Always NT. (RJ45)

    • L2 Parameters
      This setting is not recommended to change.
      • TEI selection (0-127)
        Gateway identification address (0 by default, 127 max.)

      • Signaling HDLC channel (1-31)
        Gateway identifies HDLC channel (16 by default).


Synchronization

You can set a synchronization clock accordance order in table Order of synchronization.

You can added [image] or reduce [image] any of E1 link and move up [image] or down [image] their sequence. First line in the pane Order of synchronization has the highest priority.


GSM

This section defines properties for GSM modules. There are displayed 4 modules for each module card (max. 4 modules x 8 card).


GSM Modules

Defines assignment GSM modules to GSM group and allows setting SIM card.

Configuration

  • Disable
    You can define unused GSM card if you tick Disable.

  • Echo cancelation
    You can choose ON/OFF echo.

  • Roaming
    You can permit or forbid to register GSM module to roaming.

  • CLIR
    Number of calling subscriber is restricted or not.

  • AMR

    This parameter can be used to control the usage of the feature "Adaptive Multi Rate". You can choose enabled or disabled AMR.

Assignment to GSM groups

It is possible to set each module (1-32) and assign its GSM Incoming Groups and GSM Outgoing groups.

SIM card

In this window we can set:
  • PIN code
    Set number of PIN code for SIM card. Length of PIN code is 8. You can enter PIN code twice. After 2 wrong setting you must remove SIM card from Gateway and enter proper PIN code.

  • Day of credit restoration (1-31)
    Set day of month when credit is automatic restoring.

  • Credit to restore
    Set amount of credit (tariff) in minutes, which is restoring. Credit without limit is signified "0". You can see it in pane of Diagnostics (GSM Modules Credit).

  • Remaining credit
    Set amount of remaining minutes, which you have not spend yet, these will be rolled over to the next month and added to your credit.

  • First count (in seconds)
    First count (in seconds)

  • Next count (in seconds)
    Length of the next period (1 to 250 seconds)

    Parameters First count and Next count are used for account of the real length of the call from the view of GSM operator.
    Example 1: If the call is charged per second - set both parameters to 1.
    Example 2: If you are charged immediately after answering a call for the whole first minute and then second by second - set first count to 60 and next count to 1.
    Proper setting of these parameters helps you to keep real record of the minutes spent and charged for each SIM.

Apply to All Modules

In this part you can copy setting of current module to another selected modules


GSM Incoming Group

In this section you can set rules for incoming calls.

  • Mode

    Mode, how Gateway answers to incoming calls from GSM network.
    • Receive All
      All incoming calls will be routed to ISDN interface according to following parameters.

    • Reject All
      By selecting this item you barring GSM incoming calls (the calling subscriber gets the busy tone).

    • Ignore All
      By selecting this item you ignore GSM incoming calls (but the calling subscriber gets the ringing tone).

    • Receive and reject
      By selecting this item you barring GSM incoming calls (the calling subscriber gets the busy tone) except calls, which CLIP are at list of GSM numbers (see section List of GSM numbers).

    • Receive and ignore
      By selecting this item you ignore GSM incoming calls (but the calling subscriber gets the ringing tone) except calls, which CLIP are at list of GSM numbers (see section List of GSM numbers).

    • Callback and receive
      You can activate callback (see section List of GSM numbers) in GSM incoming group which can use callback function, other calls will be routed to ISDN interface.

    • Callback and reject
      You can activate callback (see section List of GSM numbers) in GSM incoming group which can use callback function, other calls will be rejected.

    • Callback and ignore
      You can activate callback (see section List of GSM numbers) in GSM incoming group which can use callback function, other calls will be ignored.

  • Waiting for DISA (0 - 60 seconds)

    This is interval how long gateway will wait for DISA (Direct Inward System Access). If there is 0, calls will be routed immediately to ISDN interface.

  • Minimal extension length

    Minimum of DTMF digits in DTMF dial-in.

  • Maximal extension length

    Maximum number of digits which be DTMF-dialed for incoming calls. After the last DTMF dialing, which is the maximum, an ISDN call is made automatically with the currently selected DISA (or DTMF prefix if necessary).

  • Prefix

    Prefix, which the gateway adds before dialed DTMF numbers.

  • Digits to cut for callback

    You can define length of cut digits from calling number.

  • Prefix for callback

    You can define length of inserting digits before calling number.

  • Extensions

    Call is routed to extension entered in this table (in order), if the parameter Waiting for DISA (0 - 60 seconds) is setting in 0 or number of called digits is less then Minimal extension length. Maximal count of this extension is 5 extensions.

  • Modules in group

    Bottom section informs about modules in each group.


GSM outgoing groups

In this section you can set rules for outgoing calls from ISDN PRI to GSM networks.

  • GSM module selection

    • From the first
      SIM card will be switched from the first to the last in its group.

    • Cyclic
      SIM card will be switched from last engaged +1.

    • By remaining credit
      The gateway routes calls as in the cyclic mode but selects the GSM modules according to the least number of called minutes instead of cyclically.

  • Modules in group

    Bottom section informs about modules in each group.


LCR

LCR (Least Cost Routing)

A fully intelligent LCR function is the basic tool, allowing to route outgoing ISDN calls to GSM networks (or ISDN network) by the called number prefix, and calling party number and GSM module load in the particular group. Least cost routing (LCR) is the process that provides customers with cheap telephone calls. Each outgoing call from gateway interface will be routed to GSM network according to CLIP Table and Routing Table Gateway at each call check line to line and in case that called prefix is same as prefix stored in Routing Table the call will be routed via defined GSM group(s) or via E1-B interface.


CLIP Table

The Gateway stores a list of telephone numbers that are known to be charged at far greater prices. In this table is possible to create different Routing profile for sorted subscribers. Any calls of this type are not routed via Default routing profile, but via your own defined Routing profile (Routing table).


Routing Table

This is pane with Default routing profile and others routing profiles. You can Add, Edit or delete any items in this table.

  • Default routing profile

    You can set all routing item Number, Number modification and Outgoing targets list by pressing button Add:
    • Number
      You can define digits of this routing.

    • Number modification
      You can define length of cut digits and digits for inserting before called number.

    • Outgoing targets list
      You can choose one or more outgoing GSM group(s) and add to this list. It is possible to choose also routing via PSTN at the end of listing group(s). It means that in case that call is not possible to make via any outgoing GSM groups from this list, call will be routed via PSTN (E1-B interface). Maximum number of outgoing targets is five.

    • Max. digits to dial
      You can define length of digits, which will be sent. '0' means that length of called number is unknown and end of dial is recognized after timeout defined in Wait for dialing. This parameter can make the call arrangement faster.

  • Routing profile

    There is information about each routing profile (1-254) setting in CLIP. Parameters are the same as the Default routing profile.


CLIP from GSM

You can add, change or delete GSM numbers to List of GSM numbers

List of GSM numbers

This is list of numbers using in GSM Incoming Groups.


Diagnostics

In the bookmark of diagnostics you can see status of ISDN lines and GSM modules.


ISDNlines.htm

ISDN lines

This pane displays status of lines from E1 to E4.


tatus

GSM modules status

This pane displays status of each GSM module. Description of status from GSM modules is in Appendix. Double-clicking on Module displays other GSM Module Information as Module Type, IMEI, IMSI, Network ID.


DiagCredit

GSM modules credit

There is information about each GSM module and its credit.

Each module has credit X/Y.
X is Credit to restore and Y is Remaining credit from SIM card setting in GSM modules.
If X=0 SIM card is wihtout credit.


DiagStatisticInUse.htm

Statistic In Use

This pane displays how many modules is curernt in use (last 13 minutes).


Diagnostics

GSM Modules Statistics

This pane displays how many modules were in use last 24 hours.
Statistic 24 hour.gif


Description of cdr line

Cdr info file name: CDRyymmdd_Number.csv
Number of column | Description | Note
1. column: | Date | dd:mm:yyyy
2. column: | Time of start the call | hh:mm:ss
3. column: | Type of call | 1 - outgoing PBX -> GSM 2 - outgoing PBX -> PSTN 3 - incoming PSTN -> PBX 4 - incoming GSM -> PBX 5 - callback GSM -> PBX
4. column: | Caller ID | Number if calling user
5. column: | Called Number | Number of called user
6. column: | Call Length | hh:mm:ss
7. column: | Input Port | Port(PBX,PSTN,GSM)/number of channel(1-15,17-31) or number of GSM module
8. column: | Output Port | Port(PBX,PSTN,GSM)/number of channel(1-15,17-31) or number of GSM module
9. column: | Cause | Cause ETS 300 102

Example CDR071002_01.CSV
1. | 2. | 3. | 4. | 5. | 6. | 7. | 8. | 9.
Date | Time | Call Type | Caller Id | Called Number | Call Length | Input port | Output Port | Cause
2.10.2007 | 16:39:38 | Outgoing PBX->GSM | 265 | *50 | 0:00:04 | PBX/31 | GSM/3 | 16
2.10.2007 | 16:39:54 | Outgoing PBX->GSM | 265 | 444 | 0:00:03 | PBX/31 | GSM/20 | 16
2.10.2007 | 16:40:08 | Outgoing PBX->PSTN | 265 | 264 | 0:00:05 | PBX/31 | PSTN/31 | 16
2.10.2007 | 16:40:24 | Incoming PSTN->PBX | 265 | 264 | 0:00:05 | PSTN/1 | PBX/1 | 16
2.10.2007 | 16:40:52 | Incoming GSM->PBX | 0445209010 | 264 | 0:00:05 | GSM/0 | PBX/1 | 16
2.10.2007 | 16:41:11 | Incoming GSM->PBX |  |  | 0:00:08 | GSM/3 | PBX/1 | 16
2.10.2007 | 16:41:44 | Callback GSM->PBX | 0445209010 | 264 | 0:00:03 | GSM/1 | PBX/1 | 16
2.10.2007 | 16:42:31 | Outgoing PBX->GSM | 265 | *50 | 0:00:04 | PBX/31 | GSM/4 | 16
2.10.2007 | 16:42:54 | Outgoing PBX->GSM | 265 | 444 | 0:00:06 | PBX/31 | GSM/21 | 16
2.10.2007 | 16:43:14 | Outgoing PBX->GSM | 264 | *50 | 0:00:07 | PBX/31 | GSM/5 | 16


Description of status

Description of status from GSM modules

GSM Modules Status
Number | Description | Color | Note
1. | None | grey | GSM module not detected yet
2. | Initialization | grey | GSM module is initiating
3. | Not configured | grey | GSM module is not configured
4. | No Network | red | GSM module is not registered in GSM network
5. | Idle | green | GSM module is ready and OK
6. | Calling | yellow | Outgoing call to GSM nett
7. | Ringing | blue | Incoming call from GSM net
8. | Outgoing Cal | yellow | Active call
9. | Incoming Call | blue | Active call
10. | ISDN Disconnect | dark green | ISDN disconnected
11. | GSM Disconnect | dark green | GSM disconnected
12. | SMS comunication | magenta |

Error states module is out of work
Description | Color | Note
GSM modul not present | red |
Other PIN required | red |
Wrong PIN 2 times | red | Pin counter less or equal 1; see PIN code
SIM PIN required | red |
Error | red | General CME ERROR Codes (GSM 07.07)
Operation not allowed | red | CME Error (3)
Operation not supported | red | CME Error (4)
SIM not inserted | red | CME Error (10)
SIM PIN required | red | CME Error (11)
SIM PUK required | red | CME Error (12)
SIM failure | red | CME Error (13)
SIM busy | red | CME Error (14)
SIM wrong | red | CME Error (15)
Incorrect PIN | red | CME Error (16)
SIM PIN2 required | red | CME Error (17)
SIM PUK2 required | red | CME Error (18)
No network service | red | CME Error (30)
SIM blocked | red | CME Error (262)


Description of Alarm

Description of Alarm message from GSM modules

Alarm message is sending to all numbers setting in Alarm indication.
This message looks like:
Name,Number of Module,Description of error

Name: Gateway Identification setting in (General)
Number of Module: 01 - 32
Description of error: see table below.
Example:
PrimaGate,01,No Network
Description of Alarm
Description of error | Note
No Board | GSM peripheral Board is not detected (failure)
No Network | GSM module is not registered in Network
No Module | GSM Module is not detected
Bad Modul | GSM Module is detected but not initialized
Wrong PIN 2 times | Pin counter less or equal 1; see PIN code
SIM not inserted | CME Error (10)
SIM PIN required | CME Error (11)
SIM PUK required | CME Error (12)
SIM failure | CME Error (13)
SIM busy | CME Error (14)
SIM wrong | CME Error (15)
Incorrect PIN | CME Error (16)
SIM blocked | CME Error (262)
CME Error(999) | General CME ERROR Codes (GSM 07.07)


Technical Conditions

Technical Conditions for Installation

Subrack

Dimensions (W x H x D) | 482 x 133 x 360 mm (19" x 3U x 360 mm)
Weight (full configuration) | 13,8 kg
Power supply | 110-120V AC , 220-240V AC/ 50-60Hz optional
Power input | max. 380VA

GSM

Mobile network type | GSM phase 2/2+
Transmission output per channel | 900MHz / 2W, 1800MHz / 1W
VF connector | RF connector 50 Ohm GSM boards with Siemens TC35i

PRI Interface(s)

Interface | 1-4 x ISDN PRI
Signaling | Q.931-EDSS1, Q-SIG
Type (NT or TE) | NT/TE
TEI number | 0 - 63
Clock (master or slave) | Master/Slave
 | RJ 45
D channel timeslot | 16

Temperature

Working temperature range | 0°C to + 50°C
Relative humidity max. | 95% at 40°C
Air - condition | optional

Remote Control Line types

Type of line

USB2.0
Ethernet10/100 BaseT